らくがきちょう

なんとなく ~所属組織/団体とは無関係であり、個人の見解です~

IOSv でマルチキャストを設定する (BSR)

CML 上の IOSv で BSR 構成でマルチキャストを設定したサンプルコンフィグをメモしておきます。 尚、CML へインポート可能な構成ファイルは GitHub にアップロードしてあります。

1. 設定

構成

構成上のポイントは以下の通りです。

  • IOSv1 は Source、IOSv7 は Receiver として設定します
  • IOSv2 ~ 6 では OSPF を動作させ、全てのユニキャストルーティングを学習させます
  • マルチキャストは BSR 構成とします
    • IOSv2 は BSR Candidate (Priority 255) として設定します (Active)
    • IOSv6 は BSR Candidate (Priority 0) として設定します (Backup)
    • IOSv4 は RP Candidate (Priority 10) として設定します (Active)
    • IOSv5 は RP Candidate (Priority 20) として設定します (Backup)

f:id:sig9:20200803002311p:plain

コンフィグ

共通コンフィグ

マルチキャストとは関係ありませんが、全てのルータへ基本的な設定を実施しておきます。

no service config
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
!
logging buffered 65536 debugging
!
clock timezone JST +9
!
no ip domain-lookup
!
line con 0
 exec-timeout 60 0
 privilege level 15
!
scheduler allocate 20000 1000
!
no banner exec ^C
no banner incoming ^C
no banner login ^C

IOSv1

Source になる IOSv1 は no ip routing でルーティングを無効化し、ip default-gateway [ADDRESS]デフォルトゲートウェイだけ、設定しています。

hostname IOSv1
!
no ip routing
!
interface GigabitEthernet0/0
 ip address 10.0.12.1 255.255.255.0
 no shutdown
!
ip default-gateway 10.0.12.2

IOSv2

ip pim bsr-candidate Loopback0 0 255 を設定し、BSR Candidate として設定します。

hostname IOSv2
!
ip multicast-routing
!
interface GigabitEthernet0/0
 ip address 10.0.12.2 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
interface GigabitEthernet0/1
 ip address 10.0.23.2 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
router ospf 65000
 router-id 10.2.2.2
 passive-interface GigabitEthernet0/0
 network 10.0.12.0 0.0.0.255 area 0.0.0.0
 network 10.0.23.0 0.0.0.255 area 0.0.0.0
!
ip pim bsr-candidate Loopback0 0 255

IOSv3

hostname IOSv3
!
ip multicast-routing
!
interface GigabitEthernet0/0
 ip address 10.0.23.3 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
interface GigabitEthernet0/1
 ip address 10.0.34.3 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
interface GigabitEthernet0/2
 ip address 10.0.35.3 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
router ospf 65000
 router-id 10.3.3.3
 network 10.0.23.0 0.0.0.255 area 0.0.0.0
 network 10.0.34.0 0.0.0.255 area 0.0.0.0
 network 10.0.35.0 0.0.0.255 area 0.0.0.0

IOSv4

ip pim rp-candidate Loopback0 priority 10 を設定し、RP Candidate として設定します。

hostname IOSv4
!
ip multicast-routing
!
interface Loopback0
 ip address 10.4.4.4 255.255.255.255
 ip pim sparse-mode
!
interface GigabitEthernet0/0
 ip address 10.0.34.4 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
interface GigabitEthernet0/1
 ip address 10.0.46.4 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
router ospf 65000
 router-id 10.4.4.4
 network 10.0.34.0 0.0.0.255 area 0.0.0.0
 network 10.0.46.0 0.0.0.255 area 0.0.0.0
 network 10.4.4.4 0.0.0.0 area 0.0.0.0
!
ip pim rp-candidate Loopback0 priority 10

IOSv5

ip pim rp-candidate Loopback0 priority 20 を設定し、RP Candidate として設定します。

hostname IOSv5
!
ip multicast-routing
!
interface Loopback0
 ip address 10.5.5.5 255.255.255.255
 ip pim sparse-mode
!
interface GigabitEthernet0/0
 ip address 10.0.35.5 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
interface GigabitEthernet0/1
 ip address 10.0.56.5 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
router ospf 65000
 router-id 10.5.5.5
 network 10.0.35.0 0.0.0.255 area 0.0.0.0
 network 10.0.56.0 0.0.0.255 area 0.0.0.0
 network 10.5.5.5 0.0.0.0 area 0.0.0.0
!
ip pim rp-candidate Loopback0 priority 20

IOSv6

ip pim bsr-candidate Loopback0 0 1 を設定し、BSR Candidate として設定します。

hostname IOSv6
!
ip multicast-routing
!
interface GigabitEthernet0/0
 ip address 10.0.46.6 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
interface GigabitEthernet0/1
 ip address 10.0.56.6 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
interface GigabitEthernet0/2
 ip address 10.0.67.6 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
router ospf 65000
 router-id 10.6.6.6
 passive-interface GigabitEthernet0/2
 network 10.0.46.0 0.0.0.255 area 0.0.0.0
 network 10.0.56.0 0.0.0.255 area 0.0.0.0
 network 10.0.67.0 0.0.0.255 area 0.0.0.0
!
ip pim bsr-candidate Loopback0 0 1
ip pim spt-threshold infinity

IOSv7

Receiver になる IOSv7 は Source となる IOSv1 同様、no ip routing でルーティングを無効化し、ip default-gateway [ADDRESS]デフォルトゲートウェイだけ、設定しています。 マルチキャストの Receiver として動作させる為に ip igmp join-group [MCAST-ADDR]マルチキャストグループに参加させます。

hostname IOSv7
!
no ip routing
!
interface GigabitEthernet0/0
 ip address 10.0.67.7 255.255.255.0
 ip igmp join-group 224.1.1.1
 no shutdown
!
ip default-gateway 10.0.67.6

2. 状態確認

2-1. show ip pim rp mapping

IOSv1

IOSv1# show ip pim rp mapping
PIM Group-to-RP Mappings

IOSv2

IOSv2# show ip pim rp mapping
PIM Group-to-RP Mappings
This system is the Bootstrap Router (v2)

Group(s) 224.0.0.0/4
  RP 10.4.4.4 (?), v2
    Info source: 10.4.4.4 (?), via bootstrap, priority 10, holdtime 150
         Uptime: 00:00:59, expires: 00:02:27
  RP 10.5.5.5 (?), v2
    Info source: 10.5.5.5 (?), via bootstrap, priority 20, holdtime 150
         Uptime: 00:00:58, expires: 00:01:26

IOSv3

IOSv3# show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 10.4.4.4 (?), v2
    Info source: 10.2.2.2 (?), via bootstrap, priority 10, holdtime 150
         Uptime: 00:00:59, expires: 00:02:25
  RP 10.5.5.5 (?), v2
    Info source: 10.2.2.2 (?), via bootstrap, priority 20, holdtime 150
         Uptime: 00:00:58, expires: 00:02:24

IOSv4

IOSv4# show ip pim rp mapping
PIM Group-to-RP Mappings
This system is a candidate RP (v2)

Group(s) 224.0.0.0/4
  RP 10.4.4.4 (?), v2
    Info source: 10.2.2.2 (?), via bootstrap, priority 10, holdtime 150
         Uptime: 00:01:03, expires: 00:02:26
  RP 10.5.5.5 (?), v2
    Info source: 10.2.2.2 (?), via bootstrap, priority 20, holdtime 150
         Uptime: 00:01:02, expires: 00:02:26

IOSv5

IOSv5# show ip pim rp mapping
PIM Group-to-RP Mappings
This system is a candidate RP (v2)

Group(s) 224.0.0.0/4
  RP 10.4.4.4 (?), v2
    Info source: 10.2.2.2 (?), via bootstrap, priority 10, holdtime 150
         Uptime: 00:01:02, expires: 00:02:26
  RP 10.5.5.5 (?), v2
    Info source: 10.2.2.2 (?), via bootstrap, priority 20, holdtime 150
         Uptime: 00:01:01, expires: 00:02:24

IOSv6

IOSv6# show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 10.4.4.4 (?), v2
    Info source: 10.2.2.2 (?), via bootstrap, priority 10, holdtime 150
         Uptime: 00:01:03, expires: 00:02:24
  RP 10.5.5.5 (?), v2
    Info source: 10.2.2.2 (?), via bootstrap, priority 20, holdtime 150
         Uptime: 00:01:02, expires: 00:02:26

IOSv7

IOSv7# show ip pim rp mapping
PIM Group-to-RP Mappings

2-2. show ip mroute

IOSv1

IOSv1# show ip mroute
IP Multicast Forwarding is not enabled.
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

IOSv2

IOSv2# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:02:06/00:02:57, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:02:05/00:02:57

IOSv3

IOSv3# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:02:10/00:02:55, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:

IOSv4

IOSv4# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:01:06/00:03:22, RP 10.4.4.4, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet0/1, Forward/Sparse, 00:01:06/00:03:22

(*, 224.0.1.40), 00:02:02/00:01:59, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:02:01/00:01:59

IOSv5

IOSv5# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:02:01/00:02:00, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:02:00/00:02:00

IOSv6

IOSv6# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:02:09/00:02:51, RP 10.4.4.4, flags: SC
  Incoming interface: GigabitEthernet0/0, RPF nbr 10.0.46.4
  Outgoing interface list:
    GigabitEthernet0/2, Forward/Sparse, 00:02:08/00:02:51

(*, 224.0.1.40), 00:02:09/00:02:54, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:02:08/00:02:54

IOSv7

IOSv7# show ip mroute
IP Multicast Forwarding is not enabled.
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

2-3. 通信確認

IOSv1

IOSv1# ping 224.1.1.1 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:
.
Reply to request 1 from 10.0.67.7, 28 ms
Reply to request 1 from 10.0.67.7, 36 ms
Reply to request 2 from 10.0.67.7, 16 ms
Reply to request 3 from 10.0.67.7, 11 ms
Reply to request 4 from 10.0.67.7, 13 ms

2-4. show ip mroute

f:id:sig9:20200803002337p:plain

IOSv1

IOSv1# show ip mroute 224.1.1.1
Group 224.1.1.1 not found

IOSv2

IOSv2# show ip mroute 224.1.1.1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:00:29/stopped, RP 10.4.4.4, flags: SPF
  Incoming interface: GigabitEthernet0/1, RPF nbr 10.0.23.3
  Outgoing interface list: Null

(10.0.12.1, 224.1.1.1), 00:00:29/00:03:04, flags: FT
  Incoming interface: GigabitEthernet0/0, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet0/1, Forward/Sparse, 00:00:29/00:03:00

IOSv3

IOSv3# show ip mroute 224.1.1.1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:00:28/stopped, RP 10.4.4.4, flags: SP
  Incoming interface: GigabitEthernet0/1, RPF nbr 10.0.34.4
  Outgoing interface list: Null

(10.0.12.1, 224.1.1.1), 00:00:28/00:02:31, flags: T
  Incoming interface: GigabitEthernet0/0, RPF nbr 10.0.23.2
  Outgoing interface list:
    GigabitEthernet0/1, Forward/Sparse, 00:00:28/00:03:02

IOSv4

IOSv4# show ip mroute 224.1.1.1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:01:46/stopped, RP 10.4.4.4, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet0/1, Forward/Sparse, 00:01:46/00:02:42

(10.0.12.1, 224.1.1.1), 00:00:28/00:02:35, flags: T
  Incoming interface: GigabitEthernet0/0, RPF nbr 10.0.34.3
  Outgoing interface list:
    GigabitEthernet0/1, Forward/Sparse, 00:00:28/00:02:31

IOSv5

IOSv5# show ip mroute 224.1.1.1
Group 224.1.1.1 not found

IOSv6

IOSv6# show ip mroute 224.1.1.1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:02:49/00:02:11, RP 10.4.4.4, flags: SC
  Incoming interface: GigabitEthernet0/0, RPF nbr 10.0.46.4
  Outgoing interface list:
    GigabitEthernet0/2, Forward/Sparse, 00:02:48/00:02:11

IOSv7

IOSv7# show ip mroute 224.1.1.1
Group 224.1.1.1 not found

3. 障害時動作

IOSv4 のインターフェイスを閉塞し、障害時動作を確認します。

3-1. インターフェイス閉塞

IOSv4

IOSv4# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
IOSv4(config)# interface range GigabitEthernet 0/0-1
IOSv4(config-if-range)# shutdown

3-2. 通信確認

IOSv1

IOSv1# ping 224.1.1.1 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:

Reply to request 0 from 10.0.67.7, 71 ms
Reply to request 1 from 10.0.67.7, 32 ms
Reply to request 2 from 10.0.67.7, 19 ms
Reply to request 3 from 10.0.67.7, 13 ms
Reply to request 4 from 10.0.67.7, 12 ms

3-3. show ip pim rp mapping

IOSv1

IOSv1# show ip pim rp mapping
PIM Group-to-RP Mappings

IOSv2

IOSv2# show ip pim rp mapping
PIM Group-to-RP Mappings
This system is the Bootstrap Router (v2)

Group(s) 224.0.0.0/4
  RP 10.5.5.5 (?), v2
    Info source: 10.5.5.5 (?), via bootstrap, priority 20, holdtime 150
         Uptime: 00:37:48, expires: 00:01:31

IOSv3

IOSv3# show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 10.5.5.5 (?), v2
    Info source: 10.2.2.2 (?), via bootstrap, priority 20, holdtime 150
         Uptime: 00:37:56, expires: 00:01:58

IOSv4

IOSv4# show ip pim rp mapping
PIM Group-to-RP Mappings
This system is a candidate RP (v2)

IOSv5

IOSv5# show ip pim rp mapping
PIM Group-to-RP Mappings
This system is a candidate RP (v2)

Group(s) 224.0.0.0/4
  RP 10.5.5.5 (?), v2
    Info source: 10.2.2.2 (?), via bootstrap, priority 20, holdtime 150
         Uptime: 00:37:59, expires: 00:01:58

IOSv6

IOSv6# show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 10.5.5.5 (?), v2
    Info source: 10.2.2.2 (?), via bootstrap, priority 20, holdtime 150
         Uptime: 00:38:09, expires: 00:01:56

IOSv7

IOSv7# show ip pim rp mapping
PIM Group-to-RP Mappings

3-4. show ip mroute

f:id:sig9:20200803005601p:plain

IOSv1

IOSv1# show ip mroute 224.1.1.1
Group 224.1.1.1 not found

IOSv2

IOSv2# show ip mroute 224.1.1.1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:03:53/stopped, RP 10.5.5.5, flags: SPF
  Incoming interface: GigabitEthernet0/1, RPF nbr 10.0.23.3
  Outgoing interface list: Null

(10.0.12.1, 224.1.1.1), 00:00:17/00:03:14, flags: FT
  Incoming interface: GigabitEthernet0/0, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet0/1, Forward/Sparse, 00:00:17/00:03:12

IOSv3

IOSv3# show ip mroute 224.1.1.1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:00:17/stopped, RP 10.5.5.5, flags: SP
  Incoming interface: GigabitEthernet0/2, RPF nbr 10.0.35.5
  Outgoing interface list: Null

(10.0.12.1, 224.1.1.1), 00:00:17/00:02:42, flags: T
  Incoming interface: GigabitEthernet0/0, RPF nbr 10.0.23.2
  Outgoing interface list:
    GigabitEthernet0/2, Forward/Sparse, 00:00:17/00:03:12

IOSv4

IOSv4# show ip mroute 224.1.1.1
Group 224.1.1.1 not found

IOSv5

IOSv5# show ip mroute 224.1.1.1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:02:32/00:03:26, RP 10.5.5.5, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet0/1, Forward/Sparse, 00:02:32/00:03:26

(10.0.12.1, 224.1.1.1), 00:00:16/00:02:44, flags: T
  Incoming interface: GigabitEthernet0/0, RPF nbr 10.0.35.3
  Outgoing interface list:
    GigabitEthernet0/1, Forward/Sparse, 00:00:16/00:03:26

IOSv6

IOSv6# show ip mroute 224.1.1.1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:38:22/00:02:46, RP 10.5.5.5, flags: SC
  Incoming interface: GigabitEthernet0/1, RPF nbr 10.0.56.5
  Outgoing interface list:

IOSv7

IOSv7# show ip mroute 224.1.1.1
Group 224.1.1.1 not found