らくがきちょう

なんとなく ~所属組織/団体とは無関係であり、個人の見解です~

Cisco VIRL 用の MikroTik CHR 7.0beta5 の qcow2 イメージ

以前に以下のメモを書きました。

しばらく前に MikroTik の RouterOS 7.x 系がベータリリースされています。 現時点では Release 7.0beta5 です。 このリリースをベースに Cisco VIRL などでも利用出来る .qcow2 イメージを作成します。

作成したイメージ

今回、作成したイメージは下記からダウンロード出来ます。

qcow2 イメージの作成

RouterOS / CHR 用の OS イメージは MikroTik のダウンロードページ からダウンロード出来ます。 CentOS8 でイメージを作成する手順は以下の通りです。

dnf -y install qemu-img unzip
curl -O https://download.mikrotik.com/routeros/7.0beta5/chr-7.0beta5.img.zip
unzip chr-7.0beta5.img.zip
qemu-img convert -O qcow2 chr-7.0beta5.img chr-7.0beta5.qcow2

VIRL へインポートする際の JSON

CHR を VIRL へインポートする際の JSON サンプルは以下の通りです。

{
  "dynamic-subtypes": [
    {
      "hw_disk_bus": "virtio", 
      "hw_ram": 512, 
      "cli_serial": 1, 
      "baseline_image": "CHR", 
      "hw_vm_extra": "", 
      "device_type": "router", 
      "config_disk_type": "disk", 
      "interface_range": 25, 
      "gui_visible": true, 
      "plugin_desc": "Cloud Hosted Router", 
      "gui_icon": "iosv", 
      "cli_protocol": "telnet", 
      "baseline_flavor": "CHR", 
      "vnc_available": false, 
      "interface_first": 2, 
      "plugin_name": "CHR", 
      "hw_vif_model": "virtio", 
      "interface_pattern": "ether{0}", 
      "deprecated_use": "", 
      "interface_management": "ether1", 
      "plugin_base": "generic"
    }
  ]
}

設定サンプル

CHR へ最低限、以下を設定してみます。

  1. インターフェイスアドレス
  2. ルーティング
  3. ホスト名

具体的な設定例は以下の通りです。

/ip/address/add address=10.0.0.1/24 interface=ether2 network=10.0.0.0
/ip route/add distance=1 gateway=10.0.0.254
/system/identity/set name=CHR-1