らくがきちょう

なんとなく

electron-packager 実行時のバージョン指定は「--version」では無く「--electron-version」が正しい

ネット上の記事に従って electron-packager でアプリケーションをパッケージングしようとしたのですが、以下のエラーになってしまいました。

Unable to determine Electron version. Please specify an Electron version

electron-packagerのversion指定におけるエラーによると「パッケージングする際、Electron のバージョン指定は --version では無く --electron-version で指定する必要がある、と書かれていました。 つまり整理すると以下です。

  コマンド
誤ったコマンド electron-packager [ディレクトリ名] [アプリ名] --platform=[OS名] --arch=[アーキテクチャ] --version=[バージョン]
正しいコマンド electron-packager [ディレクトリ名] [アプリ名] --platform=[OS名] --arch=[アーキテクチャ] --electron-version=[バージョン]

有益な記事を書いてくださった takahiro_itazuri さんに感謝します!