らくがきちょう

なんとなく

Cisco VIRL 上で vPC を設定する(メモレベル)

Cisco VIRL 上で vPC を設定した際のメモです。 詳細まで動作確認したわけでは無く、且つ、一部問題がありますので あくまでメモレベル です。

問題点

  • PortChannel の Mode 設定を lacp active にしても PortChannel が Up にならない (その前、止む無く on 設定にしている)

コンフィグ

NX-OSv-1

hostname NX-OSv-1
!
feature interface-vlan
feature lacp
feature vpc
!
vlan 1,10
!
vrf context management
  ip route 0.0.0.0/0 172.20.0.254
vpc domain 10
  role priority 100
  peer-keepalive destination 172.20.0.102 source 172.20.0.101
  peer-gateway
!
interface Vlan10
  no shutdown
  ip address 10.0.0.1/24
!
interface port-channel1
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link
!
interface port-channel10
  switchport mode trunk
  switchport trunk allowed vlan 10
  vpc 10
!
interface Ethernet1/2
  switchport mode trunk
  switchport trunk allowed vlan 10
  channel-group 10 mode on
!
interface Ethernet1/3
  channel-group 1 force mode active
!
interface mgmt0
  vrf member management
  ip address 172.20.0.101/24
  no shutdown
!
end

terminal length 0

NX-OSv-2

hostname NX-OSv-2
!
feature interface-vlan
feature lacp
feature vpc
!
vlan 1,10
!
vrf context management
  ip route 0.0.0.0/0 172.20.0.254
vpc domain 10
  role priority 200
  peer-keepalive destination 172.20.0.101 source 172.20.0.102
  peer-gateway
!
interface Vlan10
  no shutdown
  ip address 10.0.0.2/24
!
interface port-channel1
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link
!
interface port-channel10
  switchport mode trunk
  switchport trunk allowed vlan 10
  vpc 10
!
interface Ethernet1/2
  switchport mode trunk
  switchport trunk allowed vlan 10
  channel-group 10 mode on
!
interface Ethernet1/3
  channel-group 1 force mode active
!
interface mgmt0
  vrf member management
  ip address 172.20.0.102/24
  no shutdown
!
end

terminal length 0

IOSvL2

hostname IOSvL2
!
interface Port-channel10
 switchport trunk allowed vlan 10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/0
 shutdown
!
interface GigabitEthernet0/1
 switchport trunk allowed vlan 10
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 10 mode on
 no shutdown
!
interface GigabitEthernet0/2
 switchport trunk allowed vlan 10
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 10 mode on
 no shutdown
!
interface Vlan10
 ip address 10.0.0.100 255.255.255.0
 no shutdown
!
no banner exec
no banner incoming
no banner login
!
line con 0
 privilege level 15
!
line vty 0 4
 privilege level 15
 no login
!
end

terminal length 0

状態確認

NX-OSv-1

NX-OSv-1# show vpc brief
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                     : 10
Peer status                       : peer adjacency formed ok
vPC keep-alive status             : peer is alive
Configuration consistency status  : success
Per-vlan consistency status       : success
Type-2 consistency status         : success
vPC role                          : primary
Number of vPCs configured         : 1
Peer Gateway                      : Enabled
Dual-active excluded VLANs        : -
Graceful Consistency Check        : Enabled
Auto-recovery status              : Disabled
Delay-restore status              : Timer is off.(timeout = 30s)
Delay-restore SVI status          : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router    : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id    Port   Status Active vlans
--    ----   ------ -------------------------------------------------
1     Po1    up     1,10

vPC status
----------------------------------------------------------------------------
Id    Port          Status Consistency Reason                Active vlans
--    ------------  ------ ----------- ------                ---------------
10    Po10          up     success     success               10


Please check "show vpc consistency-parameters vpc <vpc-num>" for the
consistency reason of down vpc and for type-2 consistency reasons for
any vpc.

NX-OSv-2

NX-OSv-2# show vpc brief
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                     : 10
Peer status                       : peer adjacency formed ok
vPC keep-alive status             : peer is alive
Configuration consistency status  : success
Per-vlan consistency status       : success
Type-2 consistency status         : success
vPC role                          : secondary
Number of vPCs configured         : 1
Peer Gateway                      : Enabled
Dual-active excluded VLANs        : -
Graceful Consistency Check        : Enabled
Auto-recovery status              : Disabled
Delay-restore status              : Timer is off.(timeout = 30s)
Delay-restore SVI status          : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router    : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id    Port   Status Active vlans
--    ----   ------ -------------------------------------------------
1     Po1    up     1,10

vPC status
----------------------------------------------------------------------------
Id    Port          Status Consistency Reason                Active vlans
--    ------------  ------ ----------- ------                ---------------
10    Po10          up     success     success               10


Please check "show vpc consistency-parameters vpc <vpc-num>" for the
consistency reason of down vpc and for type-2 consistency reasons for
any vpc.