らくがきちょう

なんとなく

MikroTik で指定した時間に・指定したスクリプトを実行する

MikroTik の RouterOS では「指定した時間に・指定したコマンド(スクリプト)を実行する」という設定が出来ます。お子さんがいる家庭では「子供が深夜まで夢中になって困る」という悩みをお持ちかも知れませんが、RouterOS を使うと例えば「子供用の SSID は夜 9 時になったらオフ/朝 7 時になったらオン(大人用の SSID は 24 時間使える)」という設定が出来ます。家電店で手に入る一般的なワイヤレス製品でも類似の機能はあるかも知れませんが、RouterOS の場合はより柔軟性高く、きめ細やかな設定が可能です。「自分でスクリプトさえ書ければ」ですが…

1 分おきに「インターフェイス番号 1」を Down/Up させる設定例は以下の通りです。

/system script add name=INTERFACE-DOWN owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="/interface set numbers=1 disabled=yes"
/system script add name=INTERFACE-UP owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="/interface set numbers=1 disabled=no"

/system scheduler add interval=2m name=SCHEDULE-DOWN on-event=INTERFACE-DOWN start-date=jan/12/2017 start-time=00:00:00
/system scheduler add interval=2m name=SCHEDULE-UP on-event=INTERFACE-UP start-date=jan/12/2017 start-time=00:01:00