らくがきちょう

なんとなく

MikroTik で NTP サーバと同期させるには

いずれのメーカー製品であっても、サーバ / ネットワーク製品であっても、管理の都合上、正確に時刻同期されていることは重要です。今回は RouterOS で NTP を用いた時刻同期の設定方法について記載します。

タイムゾーンの設定

まず、タイムゾーンの設定を行っておきます。WebUI で設定する場合は System → Clock に設定項目があります。デフォルト状態では以下の通り、GMT からのオフセットが「ゼロ」になっていました。

[admin@MikroTik] > /system clock print
                  time: 16:27:57
                  date: nov/22/2015
  time-zone-autodetect: yes
        time-zone-name: manual
            gmt-offset: +00:00

タイムゾーンを「Asis/Tokyo」(GMT +09:00)に設定します。

/system clock set time-zone-name=Asia/Tokyo

設定されたことを確認しておきます。

[admin@MikroTik] > /system clock print
                  time: 01:30:50
                  date: nov/23/2015
  time-zone-autodetect: no
        time-zone-name: Asia/Tokyo
            gmt-offset: +09:00

時刻同期の設定

次に時刻同期の設定を行います。WebUI で設定する場合は System → SNTP Client に設定項目があります。未設定状態だと以下のように表示されます。

[admin@MikroTik] > /system ntp client print
           enabled: no
  server-dns-names:
              mode: broadcast

NTP サーバを設定します。今回はインターネットマルチフィードの NTP サーバを参照させて頂きました。

/system ntp client set enabled=yes primary-ntp=210.173.160.27 secondary-ntp=210.173.160.57

再度、状態を確認します。上手く時刻同期出来ました。

[admin@MikroTik] > /system ntp client print
             enabled: yes
         primary-ntp: 210.173.160.27
       secondary-ntp: 210.173.160.57
    server-dns-names:
                mode: unicast
       poll-interval: 4m16s
       active-server: 210.173.160.27
    last-update-from: 210.173.160.27
  last-update-before: 1m44s870ms
     last-adjustment: 142ms655us