読者です 読者をやめる 読者になる 読者になる

らくがきちょう

なんとなく

Mikrotik を PPPoE サーバとしてコンフィグする

MikroTik Network

検証時、手軽に使える PPPoE サーバがあると便利な場合があります。今回は Mikrotik を PPPoE サーバとしてコンフィグしてみます。

構成

以下の構成で検証しました。RoS(RouterOS)のバージョンは 6.30.2 を使いました。RoS-0 が PPPoE サーバ、RoS-1 と RoS-2 が PPPoE クライアントという役割です。

f:id:sig9:20150812233057p:plain

パラメータ

パラメータは以下としました。

項目
PPPoE 接続時に割り当てるアドレス範囲 10.0.0.100-10.0.0.199
ローカルアドレス 10.0.0.1
DNS サーバアドレス (1) 8.8.8.8
DNS サーバアドレス (2) 8.8.4.4

ユーザ情報は以下としました。

ユーザ名 パスワード
USER1 PASSWORD1
USER2 PASSWORD2

コンフィグ

RoS-0(PPPoE サーバ)のコンフィグ

/system identity set name=RoS-0

/ip pool
add name="POOL" ranges=10.0.0.100-10.0.0.199

/ppp profile
add name="PROFILE" local-address=10.0.0.1 remote-address=POOL dns-server=8.8.8.8,8.8.4.4

/ppp secret
add name=USER1 password=PASSWORD1 service=pppoe profile=PROFILE
add name=USER2 password=PASSWORD2 service=pppoe profile=PROFILE

/interface pppoe-server server
add service-name=internet interface=ether2 default-profile=PROFILE disabled=no
add service-name=internet interface=ether3 default-profile=PROFILE disabled=no

RoS-1(PPPoE クライアント)のコンフィグ

/system identity set name=RoS-1

/interface pppoe-client
add name=PPPoE-CLIENT user=USER1 password=PASSWORD1 interface=ether2 service-name=internet add-default-route=yes use-peer-dns=yes disabled=no

RoS-2(PPPoE クライアント)のコンフィグ

/system identity set name=RoS-2

/interface pppoe-client
add name=PPPoE-CLIENT user=USER2 password=PASSWORD2 interface=ether2 service-name=internet add-default-route=yes use-peer-dns=yes disabled=no

状態確認

RoS-0(PPPoE サーバ)での状態確認

[admin@RoS-0] > /ip address print
Flags: X - disabled, I - invalid, D - dynamic
 #   ADDRESS            NETWORK         INTERFACE
 0 D 10.0.0.1/32        10.0.0.199      <pppoe-USER1>
 1 D 10.0.0.1/32        10.0.0.198      <pppoe-USER2>

RoS-1(PPPoE クライアント)での状態確認

RoS-1 では 10.0.0.199 が割り当てられていました。

[admin@RoS-1] > /ip address print
Flags: X - disabled, I - invalid, D - dynamic
 #   ADDRESS            NETWORK         INTERFACE
 0 D 10.0.0.199/32      10.0.0.1        PPPoE-CLIENT

RoS-2(PPPoE クライアント)での状態確認

RoS-2 では 10.0.0.198 が割り当てられていました。PPPoE 接続時に限らず、RouterOS では Pool 内のアドレスを老番から割り当てるようです。

[admin@RoS-2] > /ip address print
Flags: X - disabled, I - invalid, D - dynamic
 #   ADDRESS            NETWORK         INTERFACE
 0 D 10.0.0.198/32      10.0.0.1        PPPoE-CLIENT