読者です 読者をやめる 読者になる 読者になる

らくがきちょう

なんとなく

MikroTik(CCR / RouterBoard)で BGP を動かしてみる

Mikrotik 製品で基本的な BGP 機能を設定してみました。詳細は後述しますが、以下パターンで xBGP 接続しました。

No. xBGP 概要 起点 終点
1 eBGP Cisco と Mikrotik Catalyst 3750 CCR(Tile)
2 iBGP Mikrotik 同士 CCR(Tile) RB951(mips
3 iBGP Mikrotik 同士 RB951(mips RB951(mips

設定は全て、CLI のみで実施しています。

所感

先に所感を記載します。Mikrotik 製品に習熟しているわけでは無いので、的はずれな点もあるかも知れません。青字は良いと思った点、赤字は改善が必要と感じた点です。

  • OSPF / BGP ともにスムーズに設定出来、スムーズに動作した
  • eBGP 部分は Cisco と接続したが、全くトラブルは無かった
  • OSPF / BGP いずれも基本的な設定をする限りは「コマンドが無い」「機能が無い」ということは無かった(状態確認コマンドは不足しているように感じたが、ここは後述)
  • Mikrotik 製品は CPU やメモリリソースが潤沢な為、ダイナミックルーティングの計算処理自体はかなり軽快に動作しているように感じた
  • CPU アーキテクチャに依存するような部分は無いと思うが、予想通り、Tile と mips 間で接続しても、全く問題無かった
  • BGP で送信(Advertise)している経路は表示できたが、受信(Receive)している経路だけを表示するコマンドを見つけられなかった
  • ip route print でルーティングテーブル全体は確認出来るが、BGP テーブルだけを確認するコマンドを見つけられなかった
  • ip route print detail でルーティングテーブルの詳細表示は出来るが、特定の Prefix だけを抽出して表示することが出来なかった(引数に特定 Prefix を指定するコマンドが見つけられなかった)。これは運用上、かなり厳しいと思われる。但し、WebUI / WinBox からであれば、特定経路をクリックすることで該当経路だけの詳細を表示することが可能だった
  • OSPF や BGP にデフォルトのインスタンスが設定されており、これを削除する方法が分からなかった(無効には出来る)。そもそもデフォルトでは「設定が無い」ことが好ましいと思う

尚、以下は検証していません。

  • 大量の経路を保持させた際の挙動やパフォーマンス確認
  • BGP 属性(Attribute)の操作に伴う経路の切り替わり
  • Route Reflector や Confederation のような、大規模環境向け設定の挙動(もしくは、設定の可否)

検証環境

検証で利用したルータは以下の通りです。

番号 メーカー 型番 OS バージョン
1 Cisco WS-C3750-24TS 12.2(46)SE
2 Mikrotik CCR1009-8G-1S-1S+ 6.29.1
3 Mikrotik RB951Ui-2HnD 6.29.1
4 Mikrotik RB951Ui-2HnD 6.29.1

構成は以下の通りです。

f:id:sig9:20150705030610p:plain

初期設定

初期設定は以下の通りです。

1-Cisco の初期設定

Cisco 側では eBGP で経路を配信する為、Loopback 1 〜 10 を設定しました。また、プラットフォームに Catalyst 3750 を使っているのでデフォルトではルーティングが無効な為、ip routing コマンドを設定してルーティングを有効化しています。

hostname 1-Cisco
!
ip routing
!
interface Loopback1
 ip address 10.0.1.1 255.255.255.0
!
interface Loopback2
 ip address 10.0.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.0.3.1 255.255.255.0
!
interface Loopback4
 ip address 10.0.4.1 255.255.255.0
!
interface Loopback5
 ip address 10.0.5.1 255.255.255.0
!
interface Loopback6
 ip address 10.0.6.1 255.255.255.0
!
interface Loopback7
 ip address 10.0.7.1 255.255.255.0
!
interface Loopback8
 ip address 10.0.8.1 255.255.255.0
!
interface Loopback9
 ip address 10.0.9.1 255.255.255.0
!
interface Loopback10
 ip address 10.0.10.1 255.255.255.0
!
interface FastEthernet1/0/1
 no switchport
 ip address 192.168.12.1 255.255.255.0
!
router bgp 65001
 no synchronization
 no auto-summary
 !
 network 10.0.1.0 mask 255.255.255.0
 network 10.0.2.0 mask 255.255.255.0
 network 10.0.3.0 mask 255.255.255.0
 network 10.0.4.0 mask 255.255.255.0
 network 10.0.5.0 mask 255.255.255.0
 network 10.0.6.0 mask 255.255.255.0
 network 10.0.7.0 mask 255.255.255.0
 network 10.0.8.0 mask 255.255.255.0
 network 10.0.9.0 mask 255.255.255.0
 network 10.0.10.0 mask 255.255.255.0
 !
 neighbor 192.168.12.2 remote-as 65002

2-CCR の初期設定

/ip address add address=192.168.12.2/24 interface=ether2 network=192.168.12.0
/ip address add address=192.168.23.2/24 interface=ether3 network=192.168.23.0
/ip address add address=192.168.24.2/24 interface=ether4 network=192.168.24.0
/ip address add address=172.16.1.2 interface=loopback network=172.16.1.2
/system identity set name=2-CCR

3-RB951 の初期設定

/ip address add address=192.168.23.3/24 interface=ether2 network=192.168.23.0
/ip address add address=192.168.34.3/24 interface=ether4 network=192.168.34.0
/ip address add address=172.16.1.3 interface=loopback network=172.16.1.3
/system identity set name=3-RB951

4-RB951 の初期設定

/ip address add address=192.168.24.4/24 interface=ether2 network=192.168.24.0
/ip address add address=192.168.34.4/24 interface=ether3 network=192.168.34.0
/ip address add address=192.168.45.4/24 interface=ether4 network=192.168.45.0
/ip address add address=172.16.1.4 interface=loopback network=172.16.1.4
/system identity set name=4-RB951

OSPF の設定

OSPF や BGP で Router-ID に物理的な Up/Down の影響を受けない Loopback インターフェイスを Router-ID に指定するのがセオリーです。Mikrotik 製品では多様なインターフェイスを設定可能ではあるものの、「Loopback」というインターフェイス種別はありません。しかし、どの物理インターフェイスも参照しない Bridge インターフェイスを設定することで、あたかも Cisco 等の Loopback インターフェイスのように振る舞わせることが可能です。上記を踏まえ、Mikrotik 製品で OSPF を設定してみます。

2-CCR の OSPF 設定

/interface bridge add name=loopback
/ip address add address=172.16.1.2/32 interface=loopback
/routing ospf instance set 0 router-id=172.16.1.2
/routing ospf interface add interface=ether2 passive=yes
/routing ospf network add network=172.16.1.2/32 area=backbone
/routing ospf network add network=192.168.12.0/24 area=backbone
/routing ospf network add network=192.168.23.0/24 area=backbone
/routing ospf network add network=192.168.24.0/24 area=backbone

3-RB951 の OSPF 設定

/interface bridge add name=loopback
/ip address add address=172.16.1.3/32 interface=loopback
/routing ospf instance set 0 router-id=172.16.1.3
/routing ospf network add network=172.16.1.3/32 area=backbone
/routing ospf network add network=192.168.23.0/24 area=backbone
/routing ospf network add network=192.168.34.0/24 area=backbone

4-RB951 の OSPF 設定

/interface bridge add name=loopback
/ip address add address=172.16.1.4/32 interface=loopback
/routing ospf instance set 0 router-id=172.16.1.4
/routing ospf network add network=172.16.1.4/32 area=backbone
/routing ospf network add network=192.168.24.0/24 area=backbone
/routing ospf network add network=192.168.34.0/24 area=backbone
/routing ospf network add network=192.168.45.0/24 area=backbone

BGP の設定

Mikrotik の Wiki では静的ルートを BGP に再配布しないように、redistribute-static=no という設定がされていました。しかし、今回の検証構成では静的ルートに限らず、あらゆる再配布設定が無効になっていた為、明示的にこの設定をする必要は無いと思われます(設定しても影響は無いと思います)。尚、Mikrotik 製品の BGP Hold Time は Cisco 製品と同じく、デフォルト 180 秒になっていました。また、eBGP / iBGP 問わず、デフォルトの TTL は「255」になっていました。eBGP の場合は「TTL = 1」で十分なケースが多いと思われますので、明示的に「TTL = 1」を指定しました。

2-CCR の BGP 設定

AS 65002 の内部ネットワークである、以下を network コマンドで配信します。

  1. 192.168.23.0/24
  2. 192.168.24.0/24
  3. 192.168.34.0/24
  4. 192.168.45.0/24
/routing bgp instance set default as=65002 router-id=172.16.1.2
/routing bgp peer add remote-address=192.168.12.1 remote-as=65001 ttl=1
/routing bgp peer add remote-address=172.16.1.3 nexthop-choice=force-self remote-as=65002 update-source=loopback
/routing bgp peer add remote-address=172.16.1.4 nexthop-choice=force-self remote-as=65002 update-source=loopback
/routing bgp network add network=192.168.23.0/24
/routing bgp network add network=192.168.24.0/24
/routing bgp network add network=192.168.34.0/24
/routing bgp network add network=192.168.45.0/24

3-RB951 の BGP 設定

/routing bgp instance set default as=65002 router-id=172.16.1.3
/routing bgp peer add remote-address=172.16.1.2 remote-as=65002 update-source=loopback
/routing bgp peer add remote-address=172.16.1.4 remote-as=65002 update-source=loopback

4-RB951 の BGP 設定

/routing bgp instance set default as=65002 router-id=172.16.1.4
/routing bgp peer add remote-address=172.16.1.2 remote-as=65002 update-source=loopback
/routing bgp peer add remote-address=172.16.1.3 remote-as=65002 update-source=loopback

正常時の経路確認

1-Cisco での経路確認

1-Cisco# show ip bgp
BGP table version is 15, local router ID is 10.0.10.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.0.1.0/24      0.0.0.0                  0         32768 i
*> 10.0.2.0/24      0.0.0.0                  0         32768 i
*> 10.0.3.0/24      0.0.0.0                  0         32768 i
*> 10.0.4.0/24      0.0.0.0                  0         32768 i
*> 10.0.5.0/24      0.0.0.0                  0         32768 i
*> 10.0.6.0/24      0.0.0.0                  0         32768 i
*> 10.0.7.0/24      0.0.0.0                  0         32768 i
*> 10.0.8.0/24      0.0.0.0                  0         32768 i
*> 10.0.9.0/24      0.0.0.0                  0         32768 i
*> 10.0.10.0/24     0.0.0.0                  0         32768 i
*> 192.168.23.0     192.168.12.2                           0 65002 i
*> 192.168.24.0     192.168.12.2                           0 65002 i
*> 192.168.34.0     192.168.12.2                           0 65002 i
*> 192.168.45.0     192.168.12.2                           0 65002 i

2-CCR での経路確認

[admin@2-CCR] > /ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADb  10.0.1.0/24                        192.168.12.1             20
 1 ADb  10.0.2.0/24                        192.168.12.1             20
 2 ADb  10.0.3.0/24                        192.168.12.1             20
 3 ADb  10.0.4.0/24                        192.168.12.1             20
 4 ADb  10.0.5.0/24                        192.168.12.1             20
 5 ADb  10.0.6.0/24                        192.168.12.1             20
 6 ADb  10.0.7.0/24                        192.168.12.1             20
 7 ADb  10.0.8.0/24                        192.168.12.1             20
 8 ADb  10.0.9.0/24                        192.168.12.1             20
 9 ADb  10.0.10.0/24                       192.168.12.1             20
10 ADC  172.16.1.2/32      172.16.1.2      loopback                  0
11 ADo  172.16.1.3/32                      192.168.23.3            110
12 ADo  172.16.1.4/32                      192.168.24.4            110
13 ADC  192.168.12.0/24    192.168.12.2    ether2                    0
14 ADC  192.168.23.0/24    192.168.23.2    ether3                    0
15 ADC  192.168.24.0/24    192.168.24.2    ether4                    0
16 ADo  192.168.34.0/24                    192.168.24.4            110
                                           192.168.23.3
17 ADo  192.168.45.0/24                    192.168.24.4            110

3-RB951 での経路確認

[admin@3-RB951] > /ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADb  10.0.1.0/24                        172.16.1.2              200
 1 ADb  10.0.2.0/24                        172.16.1.2              200
 2 ADb  10.0.3.0/24                        172.16.1.2              200
 3 ADb  10.0.4.0/24                        172.16.1.2              200
 4 ADb  10.0.5.0/24                        172.16.1.2              200
 5 ADb  10.0.6.0/24                        172.16.1.2              200
 6 ADb  10.0.7.0/24                        172.16.1.2              200
 7 ADb  10.0.8.0/24                        172.16.1.2              200
 8 ADb  10.0.9.0/24                        172.16.1.2              200
 9 ADb  10.0.10.0/24                       172.16.1.2              200
10 ADo  172.16.1.2/32                      192.168.23.2            110
11 ADC  172.16.1.3/32      172.16.1.3      loopback                  0
12 ADo  172.16.1.4/32                      192.168.34.4            110
13 ADo  192.168.12.0/24                    192.168.23.2            110
14 ADC  192.168.23.0/24    192.168.23.3    ether2                    0
15  Db  192.168.23.0/24                    172.16.1.2              200
16 ADo  192.168.24.0/24                    192.168.23.2            110
                                           192.168.34.4
17  Db  192.168.24.0/24                    172.16.1.2              200
18 ADC  192.168.34.0/24    192.168.34.3    ether4                    0
19  Db  192.168.34.0/24                    172.16.1.2              200
20 ADo  192.168.45.0/24                    192.168.34.4            110
21  Db  192.168.45.0/24                    172.16.1.2              200

4-RB951 での経路確認

[admin@4-RB951] > /ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADb  10.0.1.0/24                        172.16.1.2              200
 1 ADb  10.0.2.0/24                        172.16.1.2              200
 2 ADb  10.0.3.0/24                        172.16.1.2              200
 3 ADb  10.0.4.0/24                        172.16.1.2              200
 4 ADb  10.0.5.0/24                        172.16.1.2              200
 5 ADb  10.0.6.0/24                        172.16.1.2              200
 6 ADb  10.0.7.0/24                        172.16.1.2              200
 7 ADb  10.0.8.0/24                        172.16.1.2              200
 8 ADb  10.0.9.0/24                        172.16.1.2              200
 9 ADb  10.0.10.0/24                       172.16.1.2              200
10 ADo  172.16.1.2/32                      192.168.24.2            110
11 ADo  172.16.1.3/32                      192.168.34.3            110
12 ADC  172.16.1.4/32      172.16.1.4      loopback                  0
13 ADo  192.168.12.0/24                    192.168.24.2            110
14 ADo  192.168.23.0/24                    192.168.24.2            110
                                           192.168.34.3
15  Db  192.168.23.0/24                    172.16.1.2              200
16 ADC  192.168.24.0/24    192.168.24.4    ether2                    0
17  Db  192.168.24.0/24                    172.16.1.2              200
18 ADC  192.168.34.0/24    192.168.34.4    ether3                    0
19  Db  192.168.34.0/24                    172.16.1.2              200
20 ADC  192.168.45.0/24    192.168.45.4    ether4                    0
21  Db  192.168.45.0/24                    172.16.1.2              200

1-Cisco → 5-PC への Traceroute

Traceroute を実行すると、以下の順序で Hop しているのが分かります。

  1. 2-CCR(192.168.12.2)
  2. 4-RB951(192.168.24.4)
  3. 5-PC(192.168.45.5)
1-Cisco# traceroute
Protocol [ip]:
Target IP address: 192.168.45.5
Source address: 10.0.1.1
Numeric display [n]: y
Timeout in seconds [3]: 1
Probe count [3]: 1
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 192.168.45.5

  1 192.168.12.2 8 msec
  2 192.168.24.4 [AS 65002] 0 msec
  3 192.168.45.5 [AS 65002] 0 msec

トラフィックフローを図にすると以下の通りです。

f:id:sig9:20150705032924p:plain

障害時の経路確認

2-CCR と 4-RB951 の LAN ケーブルを抜線して障害を発生させ、挙動を確認します。

1-Cisco での経路確認

AS 65001 側では経路の見え方に変更はありません。

1-Cisco# show ip bgp
BGP table version is 18, local router ID is 10.0.10.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.0.1.0/24      0.0.0.0                  0         32768 i
*> 10.0.2.0/24      0.0.0.0                  0         32768 i
*> 10.0.3.0/24      0.0.0.0                  0         32768 i
*> 10.0.4.0/24      0.0.0.0                  0         32768 i
*> 10.0.5.0/24      0.0.0.0                  0         32768 i
*> 10.0.6.0/24      0.0.0.0                  0         32768 i
*> 10.0.7.0/24      0.0.0.0                  0         32768 i
*> 10.0.8.0/24      0.0.0.0                  0         32768 i
*> 10.0.9.0/24      0.0.0.0                  0         32768 i
*> 10.0.10.0/24     0.0.0.0                  0         32768 i
*> 192.168.23.0     192.168.12.2                           0 65002 i
*> 192.168.34.0     192.168.12.2                           0 65002 i
*> 192.168.45.0     192.168.12.2                           0 65002 i

2-CCR での経路確認

2-CCR 〜 4-RB951 間が LinkDown している為、AS 65002 内経路の NextHop が 1

[admin@2-CCR] > /ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADb  10.0.1.0/24                        192.168.12.1             20
 1 ADb  10.0.2.0/24                        192.168.12.1             20
 2 ADb  10.0.3.0/24                        192.168.12.1             20
 3 ADb  10.0.4.0/24                        192.168.12.1             20
 4 ADb  10.0.5.0/24                        192.168.12.1             20
 5 ADb  10.0.6.0/24                        192.168.12.1             20
 6 ADb  10.0.7.0/24                        192.168.12.1             20
 7 ADb  10.0.8.0/24                        192.168.12.1             20
 8 ADb  10.0.9.0/24                        192.168.12.1             20
 9 ADb  10.0.10.0/24                       192.168.12.1             20
10 ADC  172.16.1.2/32      172.16.1.2      loopback                  0
11 ADo  172.16.1.3/32                      192.168.23.3            110
12 ADo  172.16.1.4/32                      192.168.23.3            110
13 ADC  192.168.12.0/24    192.168.12.2    ether2                    0
14 ADC  192.168.23.0/24    192.168.23.2    ether3                    0
15  DC  192.168.24.0/24    192.168.24.2    ether4                  255
16 ADo  192.168.34.0/24                    192.168.23.3            110
17 ADo  192.168.45.0/24                    192.168.23.3            110

3-RB951 での経路確認

[admin@3-RB951] > /ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADb  10.0.1.0/24                        172.16.1.2              200
 1 ADb  10.0.2.0/24                        172.16.1.2              200
 2 ADb  10.0.3.0/24                        172.16.1.2              200
 3 ADb  10.0.4.0/24                        172.16.1.2              200
 4 ADb  10.0.5.0/24                        172.16.1.2              200
 5 ADb  10.0.6.0/24                        172.16.1.2              200
 6 ADb  10.0.7.0/24                        172.16.1.2              200
 7 ADb  10.0.8.0/24                        172.16.1.2              200
 8 ADb  10.0.9.0/24                        172.16.1.2              200
 9 ADb  10.0.10.0/24                       172.16.1.2              200
10 ADo  172.16.1.2/32                      192.168.23.2            110
11 ADC  172.16.1.3/32      172.16.1.3      loopback                  0
12 ADo  172.16.1.4/32                      192.168.34.4            110
13 ADo  192.168.12.0/24                    192.168.23.2            110
14 ADC  192.168.23.0/24    192.168.23.3    ether2                    0
15  Db  192.168.23.0/24                    172.16.1.2              200
16 ADC  192.168.34.0/24    192.168.34.3    ether4                    0
17  Db  192.168.34.0/24                    172.16.1.2              200
18 ADo  192.168.45.0/24                    192.168.34.4            110
19  Db  192.168.45.0/24                    172.16.1.2              200

4-RB951 での経路確認

[admin@4-RB951] > /ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADb  10.0.1.0/24                        172.16.1.2              200
 1 ADb  10.0.2.0/24                        172.16.1.2              200
 2 ADb  10.0.3.0/24                        172.16.1.2              200
 3 ADb  10.0.4.0/24                        172.16.1.2              200
 4 ADb  10.0.5.0/24                        172.16.1.2              200
 5 ADb  10.0.6.0/24                        172.16.1.2              200
 6 ADb  10.0.7.0/24                        172.16.1.2              200
 7 ADb  10.0.8.0/24                        172.16.1.2              200
 8 ADb  10.0.9.0/24                        172.16.1.2              200
 9 ADb  10.0.10.0/24                       172.16.1.2              200
10 ADo  172.16.1.2/32                      192.168.34.3            110
11 ADo  172.16.1.3/32                      192.168.34.3            110
12 ADC  172.16.1.4/32      172.16.1.4      loopback                  0
13 ADo  192.168.12.0/24                    192.168.34.3            110
14 ADo  192.168.23.0/24                    192.168.34.3            110
15  Db  192.168.23.0/24                    172.16.1.2              200
16  DC  192.168.24.0/24    192.168.24.4    ether2                  255
17 ADC  192.168.34.0/24    192.168.34.4    ether3                    0
18  Db  192.168.34.0/24                    172.16.1.2              200
19 ADC  192.168.45.0/24    192.168.45.4    ether4                    0
20  Db  192.168.45.0/24                    172.16.1.2              200

1-Cisco → 5-PC への Traceroute

Traceroute を実行すると、以下の順序で Hop しているのが分かります。障害箇所を迂回しています。

  1. 2-CCR(192.168.12.2)
  2. 3-RB951(192.168.23.3)
  3. 4-RB951(192.168.24.4)
  4. 5-PC(192.168.45.5)
1-Cisco# traceroute
Protocol [ip]:
Target IP address: 192.168.45.5
Source address: 10.0.1.1
Numeric display [n]: y
Timeout in seconds [3]: 1
Probe count [3]: 1
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 192.168.45.5

  1 192.168.12.2 8 msec
  2 192.168.23.3 [AS 65002] 0 msec
  3 192.168.34.4 [AS 65002] 0 msec
  4 192.168.45.5 [AS 65002] 9 msec

トラフィックフローを図にすると以下の通りです。

f:id:sig9:20150705035408p:plain