読者です 読者をやめる 読者になる 読者になる

らくがきちょう

なんとなく

Cisco ASA を PPPoE でインターネットに接続するには

Cisco ASA を PPPoE クライアントにしてインターネット接続する場合の設定例は以下の通りです。今回は以下の環境で検証しました。


設定するパラメータは以下の通りです。

項目
WAN 側のインターフェイス GigabitEthernet 0/0
LAN 側のインターフェイス GigabitEthernet 0/1
LAN 側のアドレス 172.17.1.254/24
PPPoE 接続用 ユーザ名 USERNAME@DOMAIN
PPPoE 接続用 パスワード PASSWORD

コンフィグ例は以下の通りです。

interface GigabitEthernet 0/0
 nameif outside
 security-level 0
 pppoe client vpdn group GROUP
 ip address pppoe setroute
 no shutdown
!
interface GigabitEthernet 0/1
 nameif inside
 security-level 100
 ip address 172.17.1.254 255.255.255.0
 no shutdown
!
mtu outside 1454
sysopt connection tcpmss 1414
!
object network INSIDE-TO-INTERNET
 subnet 172.17.1.0 255.255.255.0
 nat (inside,outside) dynamic interface
!
access-list OUTSIDE-TO-IN extended permit icmp any4 any4 time-exceeded
access-list OUTSIDE-TO-IN extended permit icmp any4 any4 unreachable
!
access-group OUTSIDE-TO-IN in interface outside
!
vpdn group GROUP request dialout pppoe
vpdn group GROUP localname USERNAME@DOMAIN
vpdn group GROUP ppp authentication chap
vpdn username USERNAME@DOMAIN password PASSWORD
!
policy-map global_policy
 class inspection_default
  inspect icmp
 class class-default
  set connection decrement-ttl
!
end