読者です 読者をやめる 読者になる 読者になる

らくがきちょう

なんとなく

Cisco ASA で管理ログインを設定するには

Cisco ASA では主に以下のような管理ログインの方法が提供されています。

  1. ASDM (HTTPS)
  2. Telnet
  3. SSH

今回は TelnetSSH の設定例を記載します。

前提条件

今回は以下の OS バージョンで設定しました。

  • Cisco Adaptive Security Appliance Software Version 9.3(1)

Telnet 設定例

以下のパラメータで設定してみます。

項目
ログインパスワード PASSWORD
アクセスを受け付けるネットワーク 192.168.253.0/24

コンフィグ例は以下の通りです。

password PASSWORD
!
interface Management0/0
 management-only
 nameif management
 security-level 100
 ip address 192.168.253.1 255.255.255.0
 no shutdown
!
telnet 192.168.253.0 255.255.255.0 MANAGEMENT

ちなみにバグなのか、分かりませんが、"MANAGEMENT" という nameif 設定を実施しても、小文字の "management" になってしまいました。"INSIDE" や "OUTSIDE" は大文字で設定出来る為、一概に「大文字 NG」というわけでは無いようです。

ciscoasa# show nameif
Interface                Name                     Security
Management0/0            management               100

SSH 設定例

以下のパラメータで設定してみます。

項目
ログインユーザ名 USER
ログインパスワード PASSWORD
アクセスを受け付けるネットワーク 192.168.253.0/24

コンフィグ例は以下の通りです。

hostname ASA
domain-name EXAMPLE.LOCAL
|
username USER password PASSWORD
!
crypto key generate rsa modulus 2048
!
interface Management0/0
 management-only
 nameif management
 security-level 100
 ip address 192.168.253.1 255.255.255.0
 no shutdown
!
aaa authentication ssh console LOCAL
! 
ssh 192.168.253.0 255.255.255.0 MANAGEMENT
ssh version 2